We are continuing to verify the maintenance items.
For UK customers trying to reach us via phone, please call +441274003865
Posted May 13, 2026 - 12:49 CEST
Verifying
Verification is currently underway for the maintenance items.
Posted May 13, 2026 - 12:45 CEST
Update
Maintenance is still ongoing, so you may experience longer wait times on our phone lines and occasional delays in the Help Center. Thank you for your patience while we complete this work.
For UK customers trying to reach us via phone, please call +441274003865
Posted May 13, 2026 - 07:00 CEST
Update
We are still performing maintenance, so you may experience longer wait times on our phone lines and some delays in the Help Center. Thank you for your patience.
For UK customers trying to reach us via phone, please call +441274003865
Posted May 12, 2026 - 14:33 CEST
Update
We are still performing maintenance, so you may experience longer wait times on our phone lines and some delays in the Help Center. Thank you for your patience.
Posted May 12, 2026 - 13:52 CEST
Update
Maintenance is in progress, you may experience some wait time on phone lines the next hour.
Posted May 12, 2026 - 12:10 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2026 - 09:00 CEST
Scheduled
You may experience brief downtime or temporary instability in the Zaptec Help Center while we perform maintenance. During this time, we will upgrade articles and make some improvements.