API Disruption

Incident Report for Zaptec

Postmortem

2026-02-14 — API Disruption During the night of 2026-02-14, between 00:23 and 04:20 (CET), our public API experienced a significant disruption across all instances of the service, impacting major API-driven integrations.

Core charging subsystem and OCPP-managed chargers were not affected, so general charging continued to operate normally. However, configuration modifications on installation level were temporarily unavailable during this period.

Timeline
00:23 – Problematic behavior started
01:18 – The issue was reported to us by an integration partner
01:30 – Engineering investigation began
02:30 – Rate limiting was applied on all API routes in an attempt to recover from a restart loop, but that didn't stabilize the system. 03:10 – Application profiling was disabled to reduce overhead on the loaded system. No positive impact observed.
03:45 – /api/installation routes were isolated to a separate set of instances to contain the impact of disruption.
03:55 – Rate limiting on / was reverted; traffic patterns began to normalize
04:20 – System stabilized

Root Cause Analysis
The incident is still under active investigation. Current working theories include:
Heavy query load — Certain endpoints may have been executing queries with unexpectedly high processing costs, contributing to system strain.
Infrastructure networking issues — There are indications of underlying networking instability in the hours leading up to the incident, which may have been a contributing factor.
Increased external traffic — A significant increase in request volume on resource-intensive endpoints may have triggered or amplified the disruption.

We are continuing to investigate and will implement safeguards and optimizations on the affected endpoints to reduce the likelihood of similar incidents in the future. A follow-up update will be provided once the root cause has been confirmed.

Posted Feb 14, 2026 - 08:49 CET

Resolved

Disruption across all instances of the service, impacting major API-driven integrations.
Posted Feb 14, 2026 - 00:30 CET