We are continuing to monitor for any further issues.
Posted May 20, 2026 - 07:39 CEST
Monitoring
A fix has been implemented, and we are monitoring the results on Phone support services.
You can always reach us with a web form or using chat in the Zaptec Help Center: https://help.zaptec.com
Posted May 19, 2026 - 09:32 CEST
Update
We have identified the issue and are currently implementing a fix.
Our support phone is still not operating at full capacity, so in the meantime, we recommend contacting us via the web form or using the chat in the Zaptec Help Center: https://help.zaptec.com/
Posted May 19, 2026 - 07:28 CEST
Update
We have identified the issue and are currently implementing a fix.
Our support phone is still not operating at full capacity, so in the meantime, we recommend contacting us via the web form or using the chat in the Zaptec Help Center: https://help.zaptec.com/
Posted May 18, 2026 - 20:05 CEST
Update
The issue has been identified and a fix is being implemented. In the meantime, we recommend reaching out to us via the web form or using our chat in the Zaptec Help Center: https://help.zaptec.com/
Posted May 18, 2026 - 15:02 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 18, 2026 - 12:12 CEST
Investigating
We are currently experiencing disruptions on our phone lines. In the meantime, we recommend reaching out to us via the web form or using our chat in the Zaptec Help Center: https://help.zaptec.com/